в debian, exim

Warning: purging the environment. Suggested action: use keep_environment

exim
После обновления Exim до версии 4.84.2-1 в логах почтового сервера появились следующие сообщения: Warning: purging the environment. Suggested action: use keep_environment. Давайте разберемся!

Эти сообщения — последствия фикса уязвимости CVE-2016-1531, о котором подробнее можно почитать здесь. Там же предлагается два варианта решения возникшей проблемы — не обращать внимания на warning‘и и ждать следующей версии или добавить в конфигурационный файл exim‘а новые переменные keep_environment = и add_environment = с подходящими параметрами.

Примечание. Правда, мало кто упоминает, что при втором варианте можно вообще сломать почтовый сервер.

Проверим значения этих переменных в конфиге exim‘а:

exim4 -bP | grep environment
LOG: MAIN
  Warning: purging the environment.
Suggested action: use keep_environment.
add_environment =
keep_environment =

Добавим в конфигурационный файл /etc/exim/exim4.conf следующие строки:

...
keep_environment = X-SOURCE : X-SOURCE-ARGS : X-SOURCE-DIR
add_environment = PATH=/usr/local/sbin::/usr/local/bin::/sbin::/bin::/usr/sbin::/usr/bin::/sbin::/bin
...

Перезапустим почтовый сервер:

/etc/init.d/exim4 restart

Проверка:

exim4 -bP | grep environment
add_environment = PATH=/usr/local/sbin::/usr/local/bin::/sbin::/bin::/usr/sbin::/usr/bin::/sbin::/bin
keep_environment = X-SOURCE : X-SOURCE-ARGS : X-SOURCE-DIR

После проделанных действий в логах warning’а Warning: purging the environment. Suggested action: use keep_environment быть не должно.

Добавить комментарий